Welcome, Guest
Username Password: Remember me

Compressor will not start!
(1 viewing) (1) Guest

TOPIC: Compressor will not start!

Re: Compressor will not start! 9 years, 10 months ago #17928

  • Duane_Martin
  • OFFLINE
  • Executive Producer
  • Posts: 5513
  • Karma: 9
I followed the instructions you posted earlier in this thread and downloaded AppZapper. I then "zapped" compressor and Qmaster (which put the two programs along with some other files in the trash).

I did not mean to imply that I recommended AppZapper to any one at any time, ever. I did mention that others on the Pro Trainer list had recommended it and I regret not having qualified the statement with the fact I do not use AppZapper myself.

What I did most recently recommend is following the instructions posted in this Apple Support Document. That absolutely worked for me.
Duane E. Martin
Earth to Sky Pictures Inc.
Apple Certified Trainer - Final Cut Pro
Copyright - all rights reserved.

Re: Compressor will not start! >> unable to connect to background process! 9 years, 5 months ago #19049

  • jhall_3rd
  • OFFLINE
  • Trainee PA
  • Posts: 9
  • Karma: 0
well Duane, you are the_man when it comes to this stuff thus i am posting a riddler for you:

I'm unable to resolve the "unable to connect to background process" issue. Tried everything (really!).  The best post on the problem so far, is: www.kashum.com/blog/1152611689

BUT -- it's still not solved completely. It's not a user account issue. Your advice on trashing/reinstalling is the best -- but alas... the bug continues to terrorize us.

I was fine until updating to Leopard.

I've re-installed all but the OS from disk, updated compressor and qmaster apps to 2.01. Oh, and permissions have been repaired etc.

What happens is this: qmaster crashes everytime -- even when started from command line. The message goes like this:

6/1/08 4:44:09 PM ReportCrash[225] Saved crashreport to /Library/Logs/CrashReporter/qmasterd_2008-06-01-164404_Macintosh-2.crash using uid: 0 gid: 0, euid: 0 egid: 0

It's very ugly.  Any last thoughts before i have to rob a bank and buy sp2??? (though many report that this still does not fix it).

Last note -- i'm on a G5 PPC (tower).
>

Re: Compressor will not start! 9 years, 5 months ago #19053

  • Duane_Martin
  • OFFLINE
  • Executive Producer
  • Posts: 5513
  • Karma: 9
So you are asking me if I have anything other than the things that have always worked 100% reliably for me? No, I don't. I guess when the I found the same solution worked on a few different systems I stopped looking. I am very surprised to read that you have done everything and your system is still not working. Sorry to read that.

If you wanted to take the time to document your trouble shooting attempts I would be willing to take the time to try and identify where things are going wrong. I would suggest repeating what you have tried before; just because it did not work once doesn't mean it won't work now.
Duane E. Martin
Earth to Sky Pictures Inc.
Apple Certified Trainer - Final Cut Pro
Copyright - all rights reserved.

Re: Compressor will not start! 9 years, 5 months ago #19055

  • jhall_3rd
  • OFFLINE
  • Trainee PA
  • Posts: 9
  • Karma: 0
What i mean by "i did everything" -- is that is followed the recomendations by you as well as the one here : www.kashum.com/blog/1152611689
... removing ALL files associated with compresor and qmaster; fixed permissions, re-installed all compressor + qmaster files from disk, updated to the latest - 2.01 for compressor app & qmaster, then noticed that even after starting qmaster process via command line, noticed that qmaster always crashes immediately. Oddly enough, i can open qmaster from the applications folder and it stays alive (per activity monitor), but still get the error "unable to connect..." even when submitting a job within compressor itself (alone - without fcp).  I'm using fcp 5.0.4.... i don't think it's even possible for me to upgrade to compressor/qmaster 2.1 or above, right? I think those versions just work with fcpsp2.x.... Now i'm afraid that even if i were to buy fcpsp2.x i would be in the same boat. What's your hunch? ~J

Re: Compressor will not start! 9 years, 5 months ago #19056

  • jhall_3rd
  • OFFLINE
  • Trainee PA
  • Posts: 9
  • Karma: 0
*** NOTE: these are the files that i re-installed. Are all of these qmaster apps really necssary for running a single-machine (unclustered)?

Qmaster_Applications.pkg
Qmaster_Frameworks.pkg
Qmaster_Plugins.pkg
Qmaster_Services.pkg
Compressor.pkg

Re: Compressor will not start! 9 years, 5 months ago #19069

  • Duane_Martin
  • OFFLINE
  • Executive Producer
  • Posts: 5513
  • Karma: 9
I am looking at the Apple Support Document linked to multiple times in this thread and comparing it to the sparse details you have provided and, well, you need to go back and read the support document; that list of files you state you "re-installed" is incomplete, plus you must delete files before re-installing. As to your question if these files are required the answer to that is found in the article you linked to.

Sorry, but if you have done everything and your system is still not working, I have nothing else to offer. However, I have never personally encountered a system that could not be fixed by following the Apple Support Document, though a couple times I have fixed systems using the Apple Support Document after the systems owner "had done everything". My advice: get someone else to perform the actions required in the Apple Support Document for you. Someone not working under the presumption that it won't work.
Duane E. Martin
Earth to Sky Pictures Inc.
Apple Certified Trainer - Final Cut Pro
Copyright - all rights reserved.
Time to create page: 0.36 seconds